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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Do not connect or disconnect probes or test leads while they are connected
to a voltage source.

Ground the Product. This product is indirectly grounded through the grounding conductor of the mainframe power cord.
To avoid electric shock, the grounding conductor must be connected to earth ground. Before making connections to the input
or output terminals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Power Disconnect. The power cord disconnects the product from the power source. Do not block the power cord; it
must remain accessible to the user at all times.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.
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General Safety Summary

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.
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Preface

Preface
The RFXpress RFX100 is a software product that allows you to create digitally modulated baseband, IF, and RF signals that
can be generated through arbitrary waveform generators (AWG). This software runs as an integral part of AWG5000 and
AWG7000 series arbitrary waveform generators and can also run from an external PC.

You can use RFXpress to:

Design, debug, and develop wideband wireless communications receivers

Generate UWB-WiMedia compliant and custom signals

Generate general purpose digitally modulated IQ, IF, and RF signals

Key Features
Define baseband I and Q signals using various modulation schemes

Create single- and multi-carrier signals where each carrier is independently defined

Apply impairments such as quadrature error and imbalance or non-linear impairments

Add interferences during waveform creation

Remotely connect to Tektronix oscilloscopes and to an Agilent Performance Signal Generator (PSG®)

Remotely configure a Tektronix oscilloscope and an Agilent Performance Signal Generator (PSG®)

UWB-WiMedia
Direct RF generation of WiMedia BG1 and BG2 waveforms

Ability to generate IQ and IF waveforms including band hopping for all band groups

User-defined IF frequency including TFC pattern

Comprehensive WiMedia signal generation support for MAC and PHY layers

Ability to create UWB-WiMedia correction files, which can be automatically applied as compensation to accurately
generate signals

Ability to use Gated Noise to define noise profiles for each section of the UWB packet

Create tone nulling with intermediate values (–40 dB to +20 dB) for OFDM carrier mapping

Documentation

RFXpress RFX100 Online Help, English Tektronix part number 076-0081-XX
RFXpress RFX100 User Manual, English, (PDF) Tektronix part number 077-0045-XX
RFXpress RFX100 Quick Start User Manual, English (PDF) Tektronix part number 071-2167-XX
RFXpress RFX100 Installation Manual, English Tektronix part number 071-2166-XX
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Conventions Used in This Manual
When steps require a sequence of selections using the software interface, the ">" delimiter marks each transition between a
menu and an option. For example, File > Save.

The document MultiBand OFDM Physical Layer Specification version 1.2 (Draft) by WiMedia Alliance is referred to as the
“WiMedia standard” or “WiMedia specification”.

The term “DUT” refers to a device under test.

The terms “signal” and “waveform” are used interchangeably in this manual.
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Installation
For information on how to install this software, refer to the RFXpress Installation Manual, Tektronix part number 071-2166-XX.

Starting the Software
Start the software in either of the following ways:

From Start > Program Files > Tektronix RFXpress, click RFXpress.

Double-click the RFXpress icon on your desktop.

Closing the Software
Click File > Exit to close the software.

Software Upgrades
Periodic software upgrades may become available. The software is operational only if you have a valid option key for the
specific instrument model and serial number.

To check for upgrades:

1. Go to www.tektronix.com/software.

2. Enter the product name (RFXpress).

RFXpress RFX100 Quick Start User Manual 1
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Using the Software

Using the Software
This section covers the following information:

Getting acquainted with the software

Generating a signal

Adding impairments to the signal

Compiling a signal

Graphing a signal

Getting Acquainted with the Software
Using the Software Interface
Use the keyboard or mouse to make selections in the software.

Use menus, toolbars, check boxes, and on-screen buttons to control the software functions. Use Microsoft Windows
techniques to navigate menus and select or clear check boxes.

Generating a Single Carrier Signal
This section shows you a step-by-step procedure for creating a single carrier QPSK baseband signal.

1. Start RFXpress.

2. From the toolbar, click Select > Generic
Signal.

RFXpress RFX100 Quick Start User Manual 3



Using the Software

3. Set the signal type to IQ.

4. Click Carriers > Single Carrier.

5. Select the carrier and set the following:

Baseband Offset to 0 Hz

Amplitude to 1 Vrms

6. Ensure that the following parameters are
set:

Modulation is QPSK

Filter is Raised Cosine

Symbol rate is 1 MHz

Alpha/B*T is 0.35

Window is None

Compiling a Signal
Follow these steps to compile and generate a signal using the parameters that you just defined.

4 RFXpress RFX100 Quick Start User Manual



Using the Software

1. From the toolbar, click Compile >
Compile Settings.

2. Retain the default values as they are.
Ensure that the Automatic options are
selected.

3. Click Compile.

4. The compiled waveform is displayed in
the waveform list.

NOTE. If the waveform list is not visible, click Window > Waveform List to view it.

RFXpress RFX100 Quick Start User Manual 5
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Generating a Multi-Carrier RF Signal
1. From the toolbar, click Select > Generic

Signal.

2. Select the signal type as IF/RF.

3. Select Multi Carrier.

4. You can either add carriers directly or
delete the existing carrier and add new
ones. Select the carrier in the table and
click Delete.

5. Click Add Carriers and type 3.

6. Click Range. Set the Base Frequency
to 10 M and the Carrier Spacing to
10 M.

7. Click Add.

6 RFXpress RFX100 Quick Start User Manual



Using the Software

8. Select the first carrier from the table.
In the Setup tab, set the Base Data to
PRBS and select 15 from the adjacent
field.

9. Set the Modulation for the carrier to
QPSK.

10. Repeat steps 8 and 9 for the remaining
carriers, setting the Base Data to
PRBS 21 and PRBS 7, and Modulation
to QPSK.

Adding Power Ramping, I/Q Impairments, and Interference

1. Select the first carrier from
the table. Select the Power
Ramping tab.

2. Select Turn On.

3. Set the Ramp parameters:

Function to Linear

Time to 100 nsec

4. Set the Position parameters:

Symbol to 0

Level to 0.00

5. Click Add.

RFXpress RFX100 Quick Start User Manual 7
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6. Repeat steps 4 and 5 two more
times, adding these parameters:

Symbol = 100

Level = –60 dB
and

Symbol = 200

Level = 0 dB

7. Select the second carrier
from the table. Select the I/Q
Impairments tab.

8. In the Carrier Leakage group,
select Turn On. Set the following
parameters:

I to 5.0

Q to 5.0
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9. Select the third carrier from the
table. Select the Interference
Addition tab.

10. In the Offset group, select Turn
On. Set the Frequency to 10 M.

RFXpress RFX100 Quick Start User Manual 9
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Compile Settings and Compile

1. From the toolbar, click Compile >
Compile Settings.

2. Clear Automatic.

3. Set the Waveform Length to 500K and
the units to samples.

4. ClearAutomatic.

5. Set the Oversampling to 6.00.

6. Click Compile.

7. The compiled waveform is displayed in
the waveform list.
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Previewing Graphs

1. From the toolbar, click Graph.

2. In Graph Setup, select the folder and
click Add to add the following graphs:

Frequency Domain: Spectrum

I Vs Q: Constellation

Statistical: CCDF

3. The graphs are added to the Selected
Graphs.

4. Click OK.

5. Click Graph Preview at the lower left of
the screen to view the graphs.
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Application Examples

Application Examples

Creating a UWB Waveform to Test Your Receivers
You can create an ideal waveform and use it to test whether your receivers are operating within the WiMedia specifications.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. By default, Conformance is selected.

4. From the Select Setup, select WiMedia
Spec Example Packet.

5. The WiMedia Spec Example Packet
settings (according to Annex A of the
WiMedia specification document) are
displayed in the fields in each tab.

6. Confirm the Hopping Pattern for TF
Code 1.

7. Click Compile.

RFXpress RFX100 Quick Start User Manual 13
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8. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

I Vs Q: Constellation

Time Domain: I & Q

9. Click OK.

10. The graphs are as shown.

Characterize Receiver Design for Receiver Verification and Stress Test
You can generate a signal and use it to test your receiver at conditions just outside the boundary values specified by the
WiMedia standard.
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1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. Set the signal type to IF/RF.

4. Click Custom.

5. From the Select Setup, select WiMedia
Spec Example Packet.

6. The default values for the selected setup
and packet are shown graphically.

7. For the selected packet group, set TF
Code to User Defined.

8. To define a hopping pattern: In each
column, click the frequency that you
want to use. Set the hopping pattern to:
323323.

9. Assign a TFC number for the pattern that
you defined and click OK.

Adding Interference

1. Click Interference Addition.

2. In the Gated Noise group, select Turn
On.

3. Click Packets.

4. Click PLCP Header and set it to –10.0.
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5. From the standard toolbar, click
Compile.

6. In the Waveform List, select the IF/RF
waveform and right-click. Select Show
Graph > Time Domain.

7. Observe the noise in the header. The
noise of 10 dB is greater than the signal.

Replay a Captured Waveform to Test Receivers
You can capture a real-world signal in a real-time spectrum analyzer and play it back in multiple locations to test your DUTs.

Import an RTSA File

1. Start RFXpress.

2. Ensure that the selected application is
set to Generic Signal and the signal
type is IF/RF.
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3. From the menu, click File > Import from
File.

4. Select iqt in the Files of type field.

5. Select an iqt file.

6. Select Set as baseband signal.

7. A message appears. Click Continue.

RFXpress RFX100 Quick Start User Manual 17



Application Examples

8. Click Open.

9. The waveform list displays the I and Q
signals.

10. Note that the Input File Sample Rate
automatically takes the value with which
the iqt file was created.
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11. Select the first carrier and set the
following:

Frequency to 50 M

Amplitude to 0 dBm

12. Click Interference Addition. In the
Sinusoidal Interference group, select
Turn On.

13. Set the following:

C/I to 0 dB.

Offset from Carrier to –10 M.

14. Select the second carrier and repeat
steps 11 through 13.

RFXpress RFX100 Quick Start User Manual 19
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15. Click Compile > Compile Settings.
Ensure that Automatic is selected.

16. Click Compile. The software uses the
default compile settings to generate the
waveform.

17. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

Time Domain: I & Q

18. Click OK.

19. The Spectrum graph is as shown.
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Using Calibration to Increase the Flatness of a UWB Signal Path to the DUT
The calibration feature allows you to generate correction files that you can use during compilation to predistort the signal,
thereby increasing the flatness of the signal.

1. Set up the instruments as shown. The
instruments must be connected over a
LAN.
You will need:

A Tektronix AWG7102 with Option 06
running RFXpress software

A Tektronix DPO70804 oscilloscope
to capture the signal

Connecting cable

NOTE. Ensure that the output of the AWG
Interleave channel is connected to Channel
1 of the oscilloscope.

2. Start RFXpress.

3. From the toolbar, click Select >
UWB-WiMedia.

4. From the toolbar, click Calibration.

5. The Calibration window displays a table
of instruments connected on the network.
Select the DPO70804 oscilloscope and
click Connect. Note that the status
changes to Connected.

NOTE. You can click Test Connection to test
the status of the instrument.

6. Set the Signal Type to RF.

7. Set the Sampling Rate to 19.996576
GS/s.

8. Select Interleave.

9. Set the Average to 10.

10. Set the Band Group to 2.

11. Select Bands: 1, 2, and 3.

RFXpress RFX100 Quick Start User Manual 21
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12. Set When compiling, apply correction
files to to Ch1.

13. Set the Amplitude for Ch1 to 0.5 Vpp.

14. Set the path for Select the correction
file.

15. Click Calibrate to create the correction
file (.rfc). The calibration status is
continually updated.

16. Confirm that the correction file that was
just generated is selected.

17. Set Band Group to BandGroup 2.
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18. From the toolbar, click Compile >
Compile Settings.

19. Ensure that the correction file created
during calibration is applied to Ch1.

NOTE. Oversampling is calculated
automatically to achieve a sampling rate of
19.996576 GS/s.

20. Click Compile.

Creating a Band Group 6 Signal Using an External IQ Modulator
You can create a Band Group 6 WiMedia signal using an AWG7102 and an external IQ modulator like the Agilent PSG®.
The AWG7102 is used to generate a hopping baseband signal which will be fed to PSG to modulate it to the desired Band
Group 6 center frequency of 8184 MHz. The signal would have to be calibrated to adjust the channel mismatches. Channel
mismatches result in images and carrier leakage. Carrier leakage is caused by the offset mismatch between the channels
and images by the amplitude and skew mismtaches. To eliminate images you must calibrate the signal for all the tones. In
this application example, an extreme tone from the center frequency is taken and calibrated.
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1. You will need the following equipment,
with each piece calibrated:

A Tektronix AWG7102 with Option 06
running RFXpress software

A Tektronix DSA72004 oscilloscope
to capture the signal. The Tektronix
Ultra Wideband Spectral Analysis
software must be loaded and running
on the oscilloscope

An Agilent Performance Signal
Generator PSG® E8267D with
Option 015

A Tektronix RSA6114A Real Time
Spectrum Analyzer

Matched pair connecting cables to
connect between the PSG E8267D
and the AWG7102

2. Connect the equipment as shown.
Either the DSA72004 oscilloscope or
the RSA6114A Real Time Spectrum
Analyzer can be used as the DUT.

24 RFXpress RFX100 Quick Start User Manual



Application Examples

3. On the PSG E8267D, do the following:

Set I/Q to On.

Set I/Q Path to Wide.

Select IQ Calibration. Set
Calibration Type to Full and execute
calibration.

Set Frequency to 8184 MHz (for
BandGroup 6) and Amplitude to
0 dBm.

4. Connect the RF output of the PSG
E8267D to the oscilloscope (DUT).

5. On the AWG7102, start RFXpress.

6. Set the following:

Application to UWB-WiMedia

Signal type to IQ

Mode to Conformance

BandGroup to 6
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7. Click Compile > Compile Setting.
Ensure that Compile and Sends to is
set to Ch1 and Ch2. Click Compile to
generate the signal.

8. On the PSG E8267D, do the following:

Set Modulation to On.

Set RF to On.

9. The signal is sent to oscilloscope (DUT);
capture and demodulate it using the
Tektronix Ultra Wideband Spectral
Analysis software. If the software is
unable to decode the signal, go to step
10 to proceed with calibrating the signal.

10. Disconnect the oscilloscope and connect
the RF output of the PSG E8267D to the
RSA6114A (DUT).
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11. On the AWG7102, using a standard
waveform, generate a sine wave with a
Frequency of 700 MHz, Cycle of 500,
and the sampling rate set to No change.

12. Drag and drop the sine wave (signal) into
Ch1 and Ch2.

13. Click Ch1 and set Waveform Rotation
to 0.18 degrees. Leave Ch2 unchanged.

NOTE. On the AWG7102, the waveform
rotation value will be shown as 0.2°.

14. Click On/Off. Click Run.
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15. On the RSA6114A, do the following:

Set Frequency to 8184 MHz.

Set Span to 50 MHz.
Observe whether there is a carrier
leakage at 8184 MHz. If you find a
frequency component at 8184 MHz, go
to step 16.

16. On the PSG E8267D, do the following:

Set I/Q Adjustments to On.

Adjust the I Offset and Q Offset until
the carrier leakage reduces to the
noise floor.

You may have to adjust the values
iteratively.

17. Observe the change in the signal on the
RSA6114A.
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18. On the RSA6114A, do the following:

Set Center Frequency to
8184–700 MHz (that is 7484 MHz).

Set Span to 50 MHz.
Observe whether there is an image at a
frequency of 7484 MHz. If there is an
image, proceed to calibrate the signal. If
there is no image, proceed to step 21.

19. On the AWG7102, adjust the Amplitudes
and Channel Skews to reduce the image
to the noise floor.
You may have to adjust the values
iteratively. Observe the change in the
signal on the RSA6114A.

20. Make a note of the amplitudes and skew
values of Ch1 and Ch2.

21. Go to RFXpress and click Compile.
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22. Connect the RF output of the PSG
E8267D to the oscilloscope (DUT).

23. On the AWG7102, set the values noted
in step 20:

Amplitudes of Ch1 and Ch2.

Skew values of Ch1 and Ch2.

Waveform rotation to 0.

24. Observe that the signal is decoded on
the oscilloscope.

Simulating a MultiPath Environment for a Generic Signal
You can simulate multipath to test your receiver’s response to multipaths.

1. Start RFXpress.

2. From the toolbar, ensure that Select >
Generic signal is selected.

3. Ensure that the signal type is set to
IF/RF.

4. Ensure that Single Carrier is selected.
Keep the default values for the carrier.

5. Click Multi-Path and select Turn On.
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6. Set the following parameters:

Delay to 4 symbols

Amplitude to –1 dB

Phase to 30 degrees

7. Click Add.

8. Repeat steps 6 and 7 setting the
following parameters:

Delay to 10 symbols

Amplitude to –5 dB

Phase to 60 degrees

9. Add the following graph in Graph Setup:

Time Domain: Pulse shape

10. Click OK.
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11. From the toolbar, click Compile.

12. The pulse shape is as shown.

Introducing Real-World Impairments in a UWB Signal
You can introduce real-world impairments in a UWB signal to test your receiver in a simulated real-world environment.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. Ensure that the signal type is set to
IF/RF.

4. Ensure that the Mode is Conformance
and the Selected setup is WiMedia
Spec Example. Keep the default values
for the selected setup.

32 RFXpress RFX100 Quick Start User Manual



Application Examples

5. Click Interference Addition.

6. In the Real World Signal Interference
group box, click Turn On.

7. Click Add WiFi signal (MIMO).

8. Set the following parameters:

Frequency to 2.4 G Hz (default).

Amplitude to 30 dB.

9. Add the following graph in Graph Setup:

Frequency Domain: Spectrum

10. Click OK.
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11. From the toolbar, click Compile.

12. The spectrum is as shown.
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